Return to Project-GC

Welcome to Project-GC Q&A. Ask questions and get answers from other Project-GC users.

If you get a good answer, click the checkbox on the left to select it as the best answer.

Upvote answers or questions that have helped you.

If you don't get clear answers, edit your question to make it clearer.

Challenge Checker link not working in geo app, only on website

+1 vote
96 views

I have three new challenge caches, for which I cloned the checkers:

The links to open the checkers work on the website, but they don't work when using the official Geocaching app, nor on Cachly. 
I compared the link codes for these checkers with an earlier challenge cache of mine, which works fine, GC6P30G (http://project-gc.com/Challenges/GC6P30G/23037). I can't see any obvious differences as to why these new checker links won't work. Is it because they were cloned? Help! Thanks.
asked Aug 1, 2017 in Support and help by steve4nlanguage (230 points)

1 Answer

0 votes
 
Best answer
You can notice that the first three start with `https`, but the last one starts with `http`. It looks like the apps do not handle secure connections properly (sigh ...).

If you want to make the links working in your application, remote the `s` in the `https` and you should be fine. Also I would try to get in touch with the developers of the the geocaching apps that do not handle these links correctly.
answered Aug 1, 2017 by Jakuje (Moderator) (104,100 points)
selected Aug 1, 2017 by steve4nlanguage
Thank you for your quick response. When I went to remove the "s", I discovered the real problem: The entire "http:" was missing from the links.

When clicking the Link button at the checker page, the links produced do not include the "https:", so when I copy and pasted I didn't even notice this.

It's working now. Thanks.
well ... then it is obvious. `https://` is really needed for all the links. If it works, please, prefer the `https` variant over `http`.
...