Return to Project-GC

Welcome to Project-GC Q&A. Ask questions and get answers from other Project-GC users.

If you get a good answer, click the checkbox on the left to select it as the best answer.

Upvote answers or questions that have helped you.

If you don't get clear answers, edit your question to make it clearer.

Disabled modules are not effective in the modulesettings view

0 votes
97 views

As already discussed in several questions, there is a problem with disabling modules of profile stats. They are actually disabled, but it is not visible from the modulesettings view.

Reproducer:

  1. Open "modulesettings" view:
    https://project-gc.com/Statistics/ProfileStats?modulesettings
  2. Click on "Disable" of the first module
  3. The module has red background and is no longer visible in the public view of profile stats:
    https://project-gc.com/ProfileStats/Jakuje
  4. Open the modulesettings view again (or refresh)

Current behavior:

The disabled module has again green background as it would be enabled, button says "Disable".

Expected behavior:

The disabled module should have red background and button should say "Enable".

This is confusing, because many people assume it does not work because of this.

asked Nov 27, 2017 in Bug reports by Jakuje (Moderator) (101,630 points)
After confusing, found out it's a global problem and start to discus here already

Thanks for information!
Great, now everyone can read what the real problem is.
Please, do not add the comments as an answer, so it is on the first sight clear that it is not resolved and needs attention.

1 Answer

+3 votes
 
Best answer
A fix has been applied in the development environment.

A big thank you for a well detailed bug report, made it quite easy to solve the issue itself.

PS! I have promoted you (Jakuje) to Moderator. You should now be able to edit answers and convert them into comments (and some other things). Right now it's only you and Pinkunicorn with that access level.
answered Nov 27, 2017 by magma1447 (Admin) (216,720 points)
selected Nov 27, 2017 by Jakuje (Moderator)
For me, this fix do not work.
Same problem as before: Disabled modules are green again after refreshing. Hmm.
Spasskaiser: The fix is not applied in live environment yet. Please, give it some days, before the changes will be applied to the live environment.
...