Return to Project-GC

Welcome to Project-GC Q&A. Ask questions and get answers from other Project-GC users.

If you get a good answer, click the checkbox on the left to select it as the best answer.

Upvote answers or questions that have helped you.

If you don't get clear answers, edit your question to make it clearer.

Challenge checker search not turning up expected result

0 votes
120 views

I am trying to use the challenge checker search to see if I qualify for a particular challenge cache, namely GC5CKV2 - Challenge- Caches med højt aktivitets niveau. That's where I hit upon a perculiar behavior.

  • If I write the search term "Caches med", the desired cache comes up as the first one.
  • If I write the search term "Caches med højt", the search comes up empty.
It does not matter wheter I copy-paste the title from the cache. No result.
What gives ?
asked Aug 25, 2018 in Bug reports by Funky_Boris (8,740 points)

2 Answers

0 votes
Probably the letter "ø". A lot of non-english characters can be problematic in IT.

If you check the URL on caches on geocaching, you will see they remove Æ,Ø, Å and other non-english characters, probably to prevent issues with people not being able to type them out.

I have encountered many webpages that have had issues with those letters, and I am betting it is the issue here aswell.
answered Aug 25, 2018 by MAS83 (1,540 points)
Yeah, thought that as well. Turns out not to be the problem:

GC40QDC - Fussingø Challengecache # 2 - Multier (Denmark)

works like a charm writing "Fussingø"...
It might be that the prompt just ignores the "ø". "Fussing" would yield the same result. Searching for "ø" and "" (the empty string) yields the same result AFAICT.
Yeah, I think it is due to 'Ø' being the last character that it still works. The input probably ignores non-english characters, and then match it up against the names, so "Fussing" matches with "Fussingø", but "Hjt" does not match "Højt".
Hmm, further testing disproves my theory.

Searching "Fussøing", does not match with "Fussingø"

So that made me think it has to match 100% of the word, as searching "sø" doesn't return anything.

But if you just search 'ø' it returns everything. Then my new theory was that they see 'ø' as some sort of a wildcard? If you search 's' it returns nothing.

But then the letters 'æ' and 'å' does the same thing. So I am back to assuming it is not handling non-english properly, but I can't figure out exactly how.
+3 votes
We have made a few fixes in our development environment that seems to work better. Expect a release within a few days.
answered Aug 30, 2018 by magma1447 (Admin) (210,160 points)
Thanks, I'll be waiting :)

By the way, couldn't you have scheduled all-day-rain in Malmö on another day than today? I was there today and it poured! ;)
I would say that it was the first time in 4-5 months that it rained pretty much the whole day. :)
...