Return to Project-GC

Welcome to Project-GC Q&A. Ask questions and get answers from other Project-GC users.

If you get a good answer, click the checkbox on the left to select it as the best answer.

Upvote answers or questions that have helped you.

If you don't get clear answers, edit your question to make it clearer.

+1 vote
67 views
I have only tried this with one user with a "." in his user name, but I was able to add several users without "."s
in Bug reports by StadsAlv (10.0k points)
Ok, I will try to be a bit more clear :)

I try to use the "share" function on the virtual GPS. I select my friend "Mr.Hell" from the list of names, and the "add" button lights up just as it should. Then, when I press "save", it says "Unknown error" and the change isn't saved.

Mr.Hell is added to the list, but I am unable to save the changes.

2 Answers

0 votes
 
Best answer
What exactly isn't working? sloth96 says his add button doesn't activate, but you don't mention what doesn't work for you.

I have not been able to reproduce this upon several tries. There is nothing in the code that should care if there are any dots in the name.
by magma1447 (Admin) (225k points)
selected by StadsAlv
Ok, I will try to be a bit more clear :)

I try to use the "share" function on the virtual GPS. I select my friend "Mr.Hell" from the list of names, and the "add" button lights up just as it should. Then, when I press "save", it says "Unknown error" and the change isn't saved.

Mr.Hell is added to the list, but I am unable to save the changes.
Have you tried another web browser? If not, which browser and operating system are you using? I shared a list to him a few times just now without any issues. I turned off the messaging, so he wasn't notified about it though. In theory the messaging itself could of course be the problem, and then my reproduction case wasn't very smart.
I've tried with Firefox and chrome using Windows 7. I tried again just now and got the same error.
On my way to test windows. But a thought just hit me. How many is that list shared with? I am not sure, but I think there is a limit of 10 or so, and the error is probably not precise at all, like unknown error. So maybe it's not about the name and the dot at all.

EDIT: I have looked at the code, and I can not see any limits actually.
I also tried FF in windows, I found no issues there either.

I have tried with different casings on the name, didn't notice any issues. Try to make sure that you click in the suggestion list after you have written most of the name. That way it should be 100% correctly spelled, including casing. Though this sounds like a long shot.
That could very well be the problem, since I have 10 names in the list, though, I think I tried to add them in a different order. Will play around a bit more with it.
Yes, now I found the limit in the code anyway, I was blind. There is a limit.

It seems like it can be shared with 10 as read-only, and 10 read-write. This wasn't really the idea, and it should be checked client side first, which I have forgotten. And better feedback should of course be there. This is something I have missed to write down in the design doc, and therefore missed to implement.

Honestly there is no reason to have such low limit as 10. It was more that we wanted a limit, 10 was chosen because it also fits the simple UI. But it could just as well be 50, it wouldn't really affect the site.
That worked. Sorry for the confusion! I was pretty tired at the time I think :)
Well, at least we realized why, and I got some homework. Better feedback, and it should be already when adding them to the list, not upon save. I will most likely also increase the limit, and it will probably be for ro+rw combined, which makes more sense.
An update has been pushed to live. The feedback isn't great, but when you have reached a total of 100 in ro and rw, the add button will do nothing.
0 votes
Howdy,

 

I played with little bit and confirmed something is flaky. There may be a work around for you.

 

I tried sharing one of mine with "h.c.k.", a name pulled out of the ether.  When just entering "h.c.k." the add button did not activate.

 

However if I entered a user name without a "." let the add button "ungrey" on that name, (did not hit the button), delete the name, and then enter "h.c.k." the button stayed "ungreyed" the whole time. Clicking the button then added "h.c.k." to the list.

While not a fix, it might help you get to where you want to be.
by sloth96 (3.7k points)
...